← Back to team overview

kicad-developers team mailing list archive

Scripting Build Failing



I have been having trouble building pcbnew with -DKICAD_SCRIPTING=ON and
-DKICAD_SCRIPTING_MODULES=ON. I tried a few days ago with and without and
it's definitely one of those flags, not surprising considering the error:

[ 61%] Building CXX object
/home/kaspar/kicad/kicad.bzr2/scripting/wx_python_helpers.cpp: In
function ‘wxString* newWxStringFromPy(PyObject*)’:
error: ‘PyString_Check’ was not declared in this scope
     if( !PyString_Check( src ) && !PyUnicode_Check( src ) )
error: ‘PyString_Check’ was not declared in this scope
     if( PyString_Check( obj ) )
error: cannot convert ‘PyUnicodeObject*’ to ‘PyObject* {aka _object*}’
for argument ‘1’ to ‘Py_ssize_t PyUnicodeUCS4_AsWideChar(PyObject*,
wchar_t*, Py_ssize_t)’
                                wxStringBuffer( *result, len ), len );
make[2]: *** [pcbnew/CMakeFiles/_pcbnew.dir/__/scripting/wx_python_helpers.cpp.o]
Error 1
 make[1]: *** [pcbnew/CMakeFiles/_pcbnew.dir/all] Error 2

I just tried with -DKICAD_SCRIPTING_WXPYTHON=ON as well and that gives the
same error.

I don't have time right now to do a proper regression test but it
definitely occurs with revisions 4242 onwards.

Anyone know anything about this?



Follow ups