kicad-developers team mailing list archive
-
kicad-developers team
-
Mailing list archive
-
Message #20127
Re: [PATCH] Add axis origin marker to Footprint Editor
I'm a stickler for code that uses the same conventions when
possible. m_drawatzero should be camelCase instead of all lowercase. :)
+ switch( m_style & 0xFF )
I'm curious as to what that is doing. m_style is of type MARKER_STYLE
which is an enum with 7 items in it.
In enum MARKER_STYLE it may be nice to spell out more explicitly
CIRCLE_DOT, CIRCLE_CROSS, CIRCLE_X (I'm assuming the C means circle) to
make the code a bit more readable.
I'm not familiar enough with the rest of the code to see any possible bugs,
but nothing I don't see any glaring errors.
Jon Neal
On Thu, Sep 3, 2015 at 5:37 PM, Brian Sidebotham <brian.sidebotham@xxxxxxxxx
> wrote:
> To match functionality of the Legacy canvas I propose we extend the
> GAL ORIGIN_VIEWITEM class to allow us to add an axis origin marker
> when using the Footprint Editor. I'm sure even while in the stable
> feature-lock this is okay to commit, but an ack will be good before I
> go ahead.
>
> Also, Orson, thanks for your information about this, can you also ack
> that you're happy with the class extension? Otherwise feel free to
> contact me to implement this in another way if you'd rather...
>
> Best Regards,
>
> Brian.
>
> _______________________________________________
> Mailing list: https://launchpad.net/~kicad-developers
> Post to : kicad-developers@xxxxxxxxxxxxxxxxxxx
> Unsubscribe : https://launchpad.net/~kicad-developers
> More help : https://help.launchpad.net/ListHelp
>
>
Follow ups
References