kicad-developers team mailing list archive
Mailing list archive
Re: [RFC] Symbol library file format
On 04/01/19 15:10, Wayne Stambaugh wrote:
Is there a way to mark a unit as "power unit" (I think you mentioned
sometime back that this might be required to properly make simulation
for multi unit symbols possible while still allowing the power unit to
be separate. A power unit would also be a "must be placed unit" but i
feel separating these two might add more flexibility.)
See definition above. I'm not sure having a "required" keyword is
useful. Do you have an example in mind.
There are many parts that not only have power connections but also some
control connections that are necessary for the function of the part.
A lot of these have the control pins shared between many units so it
makes sense to move them to a specialized unit. That unit would then be
required but does not fulfill the "this is a power unit" thing. Hence my
suggestion for a more general "this unit must be placed" vs. "This unit
is optional" field. (The "This is a power unit" thing is not really
necessary for ERC. At least not if there is a "this is a required unit"
flag. The only reason i suggested that is because you mentioned that it
might be required for simulation purposes.)