← Back to team overview

kicad-developers team mailing list archive

Re: macos 10.11

 

Should we indicate anywhere about the latest stable version supported on
various OSes?  I.e. 5.0.2 is fine on 10.11.  This information is already in
the readme in the dmgs, but it might be a pain to go look for it.

I am maybe overthinking it.  Apple said they don't care enough about
supporting these users, and Apple makes money off of them.

Adam

On Thu, Feb 28, 2019, 12:36 PM Seth Hillbrand <seth@xxxxxxxxxxxxx> wrote:

> Am 2019-02-27 15:59, schrieb Wayne Stambaugh:
> > On 2/27/2019 3:30 PM, Seth Hillbrand wrote:
> >> Am 2019-02-27 14:57, schrieb Wayne Stambaugh:
> >>> Hey Adam,
> >>>
> >>> I'm guessing the impact of not supporting 10.11 would not be that
> >>> great
> >>> but I'm not a mac user so I cannot be certain.  Are there any mac
> >>> users
> >>> opposed to this?  I'm fine with this if there is no uproar from the
> >>> mac
> >>> user community.
> >>
> >> This would be a good idea from this Mac user's perspective.
> >>
> >> As a related question, can we state a policy on the website[1] that we
> >> will support OS versions that are within their developers' support
> >> cycles?  Older versions may work but we don't support them.
> >>
> >> This would allow deprecating support for Vista as well.  Ubuntu 12.04
> >> and 14.04 would be removed in April.
> >>
> >> If we are explicit in this, we can move compiler and library support
> >> forward to eliminate a number of work arounds in the codebase.  It
> >> also
> >> allows users to predict KiCad support cycles into the future.
> >>
> >> -S
> >>
> >>
> >> [1] http://kicad-pcb.org/help/system-requirements/
> >
> > This seem perfectly reasonable to me.  We could also add a note about
> > not supporting every single WM in Linux as well given the number of
> > issues that this has caused.
>
> OK.  PR is at [1].  Comments on this wording welcome.
>
> -Seth
>
> [1] https://github.com/KiCad/kicad-website/pull/387
>
> _______________________________________________
> Mailing list: https://launchpad.net/~kicad-developers
> Post to     : kicad-developers@xxxxxxxxxxxxxxxxxxx
> Unsubscribe : https://launchpad.net/~kicad-developers
> More help   : https://help.launchpad.net/ListHelp
>

References