← Back to team overview

kicad-developers team mailing list archive

Re: New package for macOS 5.1.2 stable including ngspice-30 ?


Good news, it seems like we managed to make the kicad-mac-packaging
scripts happy.

After upgrading to ngspice 30 we had to update the include path for
some unknown reason. But it seems like it should work now. The first
build has been pushed to the nightly download location. It is not been
repackaged for stable. I guess Adam will handle that if we don't
release a 5.1.3 before.

But I don't think it is ready for primetime yet, first user of the build says:

<{HD}> haha so hitting the play button crashed all of kicad
<{HD}> yep, just tried again. The whole thing crashes.
<{HD}> This is fun and all but I am going out for dinner. I will be
back in a few hours.

So if anyone else on mac could try it out? Maybe you Jeff can try it out?
I think he tested the unified version:


On Fri, 21 Jun 2019 at 11:16, Nick Østergaard <oe.nick@xxxxxxxxx> wrote:
> I see no reason to make ngspice 30 a strict minimum requirement.
> Lets just help packagers update to the latest ngspice and we are good.
> tor. 13. jun. 2019 18.33 skrev Wayne Stambaugh <stambaughw@xxxxxxxxx>:
>> On 6/10/19 4:01 PM, Carsten Schoenert wrote:
>> > Hello Wayne,
>> >
>> > Am 10.06.19 um 20:15 schrieb Wayne Stambaugh:
>> >> We cannot make ngspice 30 the minimum version.  There are far too many
>> >> linux distros where 30 is not available yet.  Please keep in mind,
>> >> Debian stable and the latest Ubuntu LTS version are the benchmarks for
>> >> dependency package versions.  I'm fine with packaging macos and windows
>> >> with 30.
>> >
>> > current Debian stable (Stretch) has KiCad version 4.0.5+dfsg1-4 in the
>> > archive and no package libngspice0 at all (not even in non-free) so
>> > there is nothing to take care on here.
>> >
>> > The current Ubuntu LTS release 18.04 (Bionic Beaver) has KiCad version
>> > 4.0.7+dfsg1-1ubuntu2 and libngspice0 version 27-1.
>> > At least the KiCad version is long long outdated. So also not really
>> > relevant too.
>> >
>> > But all relevant current Debian releases are providing a recent KiCad
>> > version and also libngspice0 in version 30.2-1 (from unstable to
>> > stretch-backports). This is also available in all Downstream of Debian
>> > means also in Ubuntu >= 'Cosmic Cuttlefish' are providing KiCad
>> > 5.0.0+dfsg1-2, but also libngspice0 in version 27. Updates wont happen.
>> >
>> > But Jean-Samuel Reynaud is providing actual versions of KiCad and also
>> > the depending libngspice0 package and they even work in the always
>> > outdated Linux Mint distro. So for me your requirements you like to set
>> > are fulfilled.
>> >
>> > And normally the application is defining the requirements. Simulations
>> > seems to be for some users an critical option. So if the maintainers of
>> > ngspice hardly suggesting to use the most recent version of ngspice in
>> > recent KiCad version I would strongly consider to increase this build
>> > dependency.
>> >
>> > In the end it's up to the KiCad maintainers to define the requirements
>> > for KiCad. It was a long road to get ngspice into Debian main but in the
>> > end it happened, big thanks to Holger again btw! So Debian has no
>> > problem to provide KiCad with a depending libngspice0 library >= 30.2.
>> >
>> Is this a problem for any of the other package devs?  If not, I have no
>> issue with bumping the minimum version to 30.  If this prevents any
>> other platforms from being built, then it will have to wait.
>> Cheers,
>> Wayne
>> _______________________________________________
>> Mailing list: https://launchpad.net/~kicad-developers
>> Post to     : kicad-developers@xxxxxxxxxxxxxxxxxxx
>> Unsubscribe : https://launchpad.net/~kicad-developers
>> More help   : https://help.launchpad.net/ListHelp

Follow ups