← Back to team overview

ladon-dev-team team mailing list archive

Roadmap

 

Here are some of the thoughts I have for the roadmap:

1. Task-Type methods.
Long ago I decided that Task-Type methods would be the feature to round-up
Ladon version 1.0.0. Task-Type methods are as the name implies the ability
to mark methods as tasks via the ladonize decorator. These methods will
automatically resolve into 3 methods. So if we have the method:
doMyTimeConsumingTask(self,arg1,arg2)

it will expand to something like:

  1. doMyTimeConsumingTask(self,arg1,arg2)
  2. doMyTimeConsumingTask_status(self, taskid)
  3. doMyTimeConsumingTask_result(self,taskid)

2. Integrated service testing via webbrowser input forms.

3. More protocols

4. Better documentation

-- 
Med venlig hilsen / Best regards
Jakob Simon-Gaarde

Follow ups