← Back to team overview

ladon-dev-team team mailing list archive

Re: [Merge] lp:~roger-lp/ladon/trunk into lp:ladon


Changes needed:

1. Here is something I don't do everyday, I'm going to ask you to to un-nice your solution (but to my defense it's for simplicity)

I have thought about the passback methods in interfaces.base.* - I think your solution is nice and everything, but I don't think we should extend the interfaces.base.Base* classes just to copy an id.
So I suggest a smaller not as nice solution for now:


I know you meen to make the nicest solution I'm just worried about extending the interfaces.base.Base* classes much more - they are bloated enough already and these are exactly the classes we want to attract other people to use for contributing new interfaces.

2. please remove the methodname argument in call_method() of the dispatcher it is redundant cause the methodname _MUST_ recide in req_dict["methodname"] - we have to stick to some kind of format in req_dict and res_dict as they are very central in Ladon's design.
That also means you have to change your jsonrpc10 interface class so the method name doesn't end up in req_dict["method"].

Best Regards Jakob

Your team Ladon Developer is subscribed to branch lp:ladon.

Follow ups