← Back to team overview

launchpad-reviewers team mailing list archive

[Merge] lp:~michael.nelson/launchpad/distro-series-difference-schema into lp:launchpad

 

The proposal to merge lp:~michael.nelson/launchpad/distro-series-difference-schema into lp:launchpad has been updated.

Description changed to:

Overview
=======
This branch is a schema patch to support displaying packages with different versions between two distroseries (specifically, a derived distroseries and its parent series).

Details of the UI at:
https://dev.launchpad.net/LEP/DerivativeDistributions

Details
=====
Some details regarding the implementation and schema design were discussed on a long-ish email thread:

https://lists.launchpad.net/launchpad-dev/msg04408.html

The decisions that came out of that discussion were:

1) Lets just store the derived series which references its parent series (rather than generalising it with two references to distroseries - we can always generalise later if and when we need to).
2) Store the source_package_name, rather than two references to SPPHs, as the SPPH references can be out of date (ie. a newer version could be published before the record is updated again). We'll have properties on the model which will always look up the latest SPPHs based on the distroseries's and source package name.
3) The actual diff off the two packages is not required (nullable), and will be generated on request. Also, once its created, its not necessarily a diff of the current packages (new versions could be uploaded since the diff was generated). Hence naming it latest_package_diff rather than simply package_diff.
4) The activity_log field was initially a comment field, but it will be used and appended to (1) by scripts, when new uploads are detected that change the state, or (2) when users add comments (eg. "We're waiting for version 1.4"), hence renaming it activity_log. I don't see a reason to add a separate comment model - but you might.
5) Initially we had just one enum for the type of difference (UNIQUE_TO_DERIVED_SERIES, MISSING_FROM_DERIVED_SERIES, DIFFERENT_VERSIONS) so that the view can query for all the records of a certain type. We were planning on having an 'ignored' flag, but after the above email discussion, it became apparent that other options would be required (IGNORED_ALWAYS, RESOLVED etc.), so the status column was added to support this enum instead of the ignored bool.

No sampledata changes.

The following branch adds the basic model code:
https://code.edge.launchpad.net/~michael.nelson/launchpad/distro-series-difference-basic-model/+merge/33885


-- 
https://code.launchpad.net/~michael.nelson/launchpad/distro-series-difference-schema/+merge/33515
Your team Launchpad code reviewers is requested to review the proposed merge of lp:~michael.nelson/launchpad/distro-series-difference-schema into lp:launchpad.



References