← Back to team overview

launchpad-reviewers team mailing list archive

[Merge] lp:~jml/launchpad/generate-ppa-logging into lp:launchpad

 

The proposal to merge lp:~jml/launchpad/generate-ppa-logging into lp:launchpad has been updated.

Description changed to:

Turns out that generate_ppa_htaccess is a blocking step in the process of buying software.  We need it to be as fast as possible, and so we need to instrument it to see where its slow.

Along the way, I've done some cleanups to code.  In an effort to reduce the line count damage, I may have gone a bit overboard in cramming changes into this diff.  Sorry.

Here's a summary:

 * Add a debug log to all cronscripts to say how long they spent running
 * Add a method to get the last activity of a cronscript
 * Add total_seconds helper to get the number of seconds in a timedelta
   * Use this helper in lots of places
 * Add write_file helper to write out a file.  Just use this helper in these tests.
 * Rename deactivateTokens to deactivateInvalidTokens, split its implementation into something that figures out what the tokens are, and something that deactivates arbitrary tokens
 * Rename getNewTokensSinceLastRun to getNewTokens
 * Change the 'getNew*' methods in generate_ppa_htaccess to take a 'since' time
 * Change both 'getNew*' methods to use the same damn since time
 * Calculate the correct since time once, and test that directly, deleting other indirect tests
 * Use matchers and helpers in the tests where possible
 * General test cleanup
 * Lots of instrumentation

Adds 31 lines of code.

For more details, see:
https://code.launchpad.net/~jml/launchpad/generate-ppa-logging/+merge/108040
-- 
https://code.launchpad.net/~jml/launchpad/generate-ppa-logging/+merge/108040
Your team Launchpad code reviewers is subscribed to branch lp:launchpad.


References