← Back to team overview

launchpad-reviewers team mailing list archive

Re: [Merge] lp:~cjwatson/launchpad/process-accepted-bugs-job into lp:launchpad

 

Review: Approve code

374	+ bug_ids = []
375	for bug_id in bugs_fixed_line.split():
376	if not bug_id.isdigit():
377	continue
389	+ bug_ids.append(int(bug_id))
390	+ return bug_ids

Excuse the terrible indentation, but what about return [int(bug_id) for bug_id in bugs_fixed_line.split() if bug_id.isdigits()]  instead of that block?

I'd also prefer to see the tests running under the process_accepted dbuser so we can pick up any missing permissions -- on say, public.job.


-- 
https://code.launchpad.net/~cjwatson/launchpad/process-accepted-bugs-job/+merge/122420
Your team Launchpad code reviewers is subscribed to branch lp:launchpad.


References