← Back to team overview

launchpad-reviewers team mailing list archive

Re: [Merge] lp:~julian-edwards/maas/packaging into lp:~maas-maintainers/maas/packaging

 

2 things:
a.) I'm pretty sure that 'lsb_release' is preferred to consuming /etc/os-version
   $ lsb_release --codename --short
   raring

b.) i'd think it makes it easier to read to put all the 12.04 changes in one place.  ie:
  if "$(lsb_release --codename --short)" == "precise";
    owner_group="dhcpd:dhcpd"
    dhcpd_owner_opts="-user dhcpd -group dhcpd"
  else
    owner_group="root:root"
    dhcpd_owner_opts=""
  fi

  Then just:
    chown $owner_group $LFILE
    exec /usr/sbin/dhcpd ${owner_group} -f -q -4 -pf $PID_FILE -cf $CONFIG_FILE -lf $LEASES_FILE $INTERFACES

-- 
https://code.launchpad.net/~julian-edwards/maas/packaging/+merge/163459
Your team Launchpad code reviewers is requested to review the proposed merge of lp:~julian-edwards/maas/packaging into lp:~maas-maintainers/maas/packaging.


References