launchpad-reviewers team mailing list archive
-
launchpad-reviewers team
-
Mailing list archive
-
Message #24203
[Merge] ~pappacena/launchpad:bugtrackercompo-matching-interface into launchpad:master
Thiago F. Pappacena has proposed merging ~pappacena/launchpad:bugtrackercompo-matching-interface into launchpad:master.
Commit message:
Renaming sourcepackagename attribute on IBugTrackerComponent to match naming conventions (and to make BugTrackerComponent.source_package_name match the interface definition)
Requested reviews:
Launchpad code reviewers (launchpad-reviewers)
For more details, see:
https://code.launchpad.net/~pappacena/launchpad/+git/launchpad/+merge/377194
Used pycharm renaming tool, and it didn't find any other usage of this attribute. Apart from that, all tests on lp.bugs.* seems to be passing after the change.
--
Your team Launchpad code reviewers is requested to review the proposed merge of ~pappacena/launchpad:bugtrackercompo-matching-interface into launchpad:master.
diff --git a/lib/lp/bugs/browser/bugtracker.py b/lib/lp/bugs/browser/bugtracker.py
index 25e8510..7d3c2cf 100644
--- a/lib/lp/bugs/browser/bugtracker.py
+++ b/lib/lp/bugs/browser/bugtracker.py
@@ -466,8 +466,8 @@ class BugTrackerEditComponentView(LaunchpadEditFormView):
linked to source packages in the Ubuntu distribution.
"""
schema = IBugTrackerComponent
- custom_widget_sourcepackagename = UbuntuSourcePackageNameWidget
- field_names = ['sourcepackagename']
+ custom_widget_source_package_name = UbuntuSourcePackageNameWidget
+ field_names = ['source_package_name']
page_title = 'Link component'
@property
diff --git a/lib/lp/bugs/interfaces/bugtracker.py b/lib/lp/bugs/interfaces/bugtracker.py
index e2414e9..ee5cb99 100644
--- a/lib/lp/bugs/interfaces/bugtracker.py
+++ b/lib/lp/bugs/interfaces/bugtracker.py
@@ -576,7 +576,7 @@ class IBugTrackerComponent(Interface):
title=_('Name'),
description=_("The name of a software component "
"as shown in Launchpad.")))
- sourcepackagename = Choice(
+ source_package_name = Choice(
title=_("Package"), required=False, vocabulary='SourcePackageName')
distribution = Choice(
title=_("Distribution"), required=False, vocabulary='Distribution')
Follow ups