← Back to team overview

launchpad-reviewers team mailing list archive

Re: [Merge] ~jugmac00/launchpad:fix-pymemcache-regression-bytes-vs-str into launchpad:master

 

For the reviewer:
- I had to remove one assertion: self.assertEqual([], hosting_fixture.getInventory.calls), which I think is ok, as getInventory is the method were the expected exception is raised
- I had to implement the two new methods also in MemcacheFixture - this is a bit dangerous, as duplicated code could be changed in one place and not in the other, and we basically test MemcacheFixture rather than the real code.
- I have not created a dedicated test to test the behavior when the Client accesses bytes instead of the expected str - I could inject bytes in MemcacheFixture._cache, but then again, we test the fixture, not the real code.
-- 
https://code.launchpad.net/~jugmac00/launchpad/+git/launchpad/+merge/411913
Your team Launchpad code reviewers is requested to review the proposed merge of ~jugmac00/launchpad:fix-pymemcache-regression-bytes-vs-str into launchpad:master.



References