launchpad-reviewers team mailing list archive
-
launchpad-reviewers team
-
Mailing list archive
-
Message #31752
Re: [Merge] ~pelpsi/launchpad:propagate-launchpad-context-to-builders into launchpad:master
I'm not sure if there is a hard reason to go for `develop`, but I'd rather go for `devel`, `development` or `local`. I'm not too fussy about it if it's the requirement
Diff comments:
> diff --git a/lib/lp/buildmaster/model/buildfarmjobbehaviour.py b/lib/lp/buildmaster/model/buildfarmjobbehaviour.py
> index 4dd258a..f44d203 100644
> --- a/lib/lp/buildmaster/model/buildfarmjobbehaviour.py
> +++ b/lib/lp/buildmaster/model/buildfarmjobbehaviour.py
> @@ -98,6 +98,14 @@ class BuildFarmJobBehaviourBase:
>
> def extraBuildArgs(self, logger=None) -> BuildArgs:
> """The default behaviour is to send only common extra arguments."""
> + launchpad_urls = {
I feel like it would be nicer to have this be a configuration of the env instead of this dictionary - let's maybe discuss it tomorrow? I understand we need to move it forward, if we don't find a way to do that nicely let's use this
> + "launchpad.net": "production",
> + "qastaging.launchpad.net": "qastaging",
> + "staging.launchpad.net": "staging",
> + "launchpad.test": "develop",
> + }
> + launchpad_server_url = config.vhost.mainsite.hostname
> + launchpad_instance = launchpad_urls.get(launchpad_server_url)
I'd add the `develop` (or another name if we change it) as the default here, eg:
```
launchpad_instance = launchpad_urls.get(launchpad_server_url, "develop")
```
and remove it from the urls list above - `launchpad.test` doesn't feel like an official hostname
> return {
> "arch_tag": self.distro_arch_series.architecturetag,
> "archive_private": self.archive.private,
--
https://code.launchpad.net/~pelpsi/launchpad/+git/launchpad/+merge/475535
Your team Launchpad code reviewers is requested to review the proposed merge of ~pelpsi/launchpad:propagate-launchpad-context-to-builders into launchpad:master.
References