← Back to team overview

launchpad-users team mailing list archive

Re: problems uploading packages to a ppa using dput


On Tue, Apr 7, 2009 at 6:43 PM, Donald Raikes <raptor@xxxxxxxxxxxxxxx> wrote:
> Hello all,
> I am new to launchpad, and have been experimenting with creating some
> new packages for ubuntu.  I created a couple of ppa's in my launchpad
> account, and have tried  to upload my newly created packages to one of
> the PPA's.
> I ran dbuild -S on the package's directory, and it completed without any
> errors.
> I then moved up to the parent and entered:
> dput personal package-version_source.changes
> dput said it completed successfully, but now 24-hours later, I have
> gotten no acknowledgement that the package has been uploaded, nor do I
> see it in my PPA when I view it online.
> ppa:
> https://ppa.launchpad.net/~draikes/personal
> Is there a way to check the status of the dput queue to see what is
> happening and/or clean it out and start over?

You are using a broken dput config:

incoming = ~draikes/testing

when it should be:

incoming = ~draikes/testing/ubuntu

as described in https://help.launchpad.net/Packaging/PPA#Uploading

We should cope fine with source uploads with 'undefined distribution',
by defaulting to ubuntu.


Celso Providelo <celso.providelo@xxxxxxxxxxxxx>
IRC: cprov,  Jabber: cprov@xxxxxxxxxx, Skype: cprovidelo
1024D/681B6469 C858 2652 1A6E F6A6 037B  B3F7 9FF2 583E 681B 6469

Follow ups