← Back to team overview

launchpad-users team mailing list archive

Launchpad webservice changes for source package publications



Anyone who uses the webservice to retrieve SourcePackagePublishingHistory 
objects will notice a change on edge when it next updates.

To be consistent with the general naming convention, several properties have 
been renamed:

datecreated is now date_created
datemadepending is now date_made_pending
datepublished is now date_published
dateremoved is now date_removed
datesuperseded is now date_superseded
displayname is now display_name
distroseries is now distro_series
scheduleddeletiondate is now scheduled_deletion_date

I'm sorry if this inconveniences anyone, but I hope you'll prefer the new 
consistent naming.