← Back to team overview

maria-developers team mailing list archive

bzr commit into MariaDB 5.1, with Maria 1.5:maria branch (knielsen:2785)

 

#At lp:maria

 2785 knielsen@xxxxxxxxxxxxxxx	2010-01-04
      Add DB_TYPE_AUTOASSIGN as a better name for DB_TYPE_UNKNOWN, which is what plugins should generally use.
      modified:
        sql/handler.h

=== modified file 'sql/handler.h'
--- a/sql/handler.h	2009-12-03 11:19:05 +0000
+++ b/sql/handler.h	2010-01-04 13:12:53 +0000
@@ -278,6 +278,11 @@ enum legacy_db_type
   DB_TYPE_FIRST_DYNAMIC=42,
   DB_TYPE_DEFAULT=127 // Must be last
 };
+/*
+  Better name for DB_TYPE_UNKNOWN. Should be used for engines that do not have
+  a hard-coded type value here.
+ */
+#define DB_TYPE_AUTOASSIGN DB_TYPE_UNKNOWN
 
 enum row_type { ROW_TYPE_NOT_USED=-1, ROW_TYPE_DEFAULT, ROW_TYPE_FIXED,
 		ROW_TYPE_DYNAMIC, ROW_TYPE_COMPRESSED,