← Back to team overview

maria-developers team mailing list archive

Re: Segmented Key Cache - Syntax section


On Thu, May 13, 2010 at 11:31 PM, Daniel Bartholomew <dbart@xxxxxxxxxxxx> wrote:
> == Segmented Key Cache Syntax ==
> New global variable: key_cache_partitions, it sets the number of
> segments in a key cache. Valid values for this variable are whole

Since we changed the name of this feature to key_cache_partitions
(after it was committed), should the name of the variable be changed
to key_cache_segments?
> Question for the developers: A key_cache_partitions value of '0' means
> the key cache will not be segmented, it will be a regular (or simple)
> key cache. A value of '1' means the key cache will be a segmented key
> cache with a single segment. Is there any benefit to having a
> "single-segment segmented key cache" compared to a regular "simple key
> cache" or are they practically the same thing?

Excellent question :-)


email: henrik.ingo@xxxxxxxxxxxxx
tel:   +358-40-5697354
www:   www.avoinelama.fi/~hingo
book:  www.openlife.cc

Follow ups