maria-developers team mailing list archive
Mailing list archive
Re: 044dfaff670: Replace handler::primary_key_is_clustered() with handler::ha_is_clustered_key()
On Feb 28, Michael Widenius wrote:
> revision-id: 044dfaff670 (mariadb-10.5.0-275-g044dfaff670)
> parent(s): 5ae74b4823a
> author: Michael Widenius <monty@xxxxxxxxxxx>
> committer: Michael Widenius <monty@xxxxxxxxxxx>
> timestamp: 2020-02-26 16:05:55 +0200
> Replace handler::primary_key_is_clustered() with handler::ha_is_clustered_key()
> This was done to both simplify the code and also to be easier to handle
> storage engines that are clustered on some other index than the primary
No, I don't get it.
Old method meant "Check if the key is a clustered and a reference key".
Just "clustered" is marked with HA_CLUSTERED_INDEX.
1. You've renamed the method but the name does not match the semantics.
It is called is_clustering_key() but it really means
"clustered AND reference key"
2. What other engine can be where the reference key isn't a primary key?
VP of MariaDB Server Engineering