← Back to team overview

maria-discuss team mailing list archive

Maria on Solaris X86



I’m having trouble getting MariaDB 5.1.42 working on Solaris 10x86. I’ve tried both the Binary package (mariadb-5.1.42-solaris11-i386) and building from source (mariadb-5.1.42). I don't know if it's something in the binary package or source code, something goofy on my system, or something goofy with how I'm building it. I'm assuming the latter, but thought I might bring it up anyway just in case it might help others running Solaris. :-)

I can’t get the binary dist to startup. Here’s the error log from the binary dist (note the hostname missing from the error log name)…

$ cat data/.err
100212 09:54:33 mysqld_safe Starting mysqld daemon with databases from /data01/mydata/mariadb-bin-tst/data ld.so.1: mysqld: fatal: relocation error: file bin/mysqld: symbol strnlen: referenced symbol not found 100212 09:54:33 mysqld_safe mysqld from pid file /data01/mydata/mariadb-bin-tst/mysql.pid ended

I’m using SunStudio 12.1 to build from source. Here’s my configure and make:

export PATH=/product01/sunstudio12.1/bin:${PATH}
export LD_LIBRARY_PATH=/usr/lib:/usr/local/lib

make distclean

ASFLAGS="-m64" \
CC="cc-5.0" \
CFLAGS="-Xa -xstrconst -g -mt -D_FORTEC_ -m64" \
CXX="CC" \
CXXFLAGS="-noex -g -mt -D_FORTEC_ -m64" \
LIBS=-lmtmalloc \
./configure \
--prefix=/product01/mysql/mariadb-5.1.42 \
--localstatedir=/product01/mysql/mariadb-5.1.42/data \
--libexecdir=/product01/mysql/mariadb-5.1.42/bin \
--with-extra-charsets=all \
--enable-thread-safe-client \
--enable-local-infile \
--with-zlib-dir=bundled \
--with-big-tables \
--with-readline \
--with-named-curses-libs=-lcurses \
--enable-assembler \
--enable-static \


gmake[1]: Entering directory `/home/mysql/jgrill/mariadb-5.1.42/dbug'
source='dbug.c' object='dbug.o' libtool=no \
DEPDIR=.deps depmode=none /bin/bash ../depcomp \
cc-5.0 -DHAVE_CONFIG_H -I. -I. -I../include -I../include -I../include -Xa -xstrconst -g -mt -D_FORTEC_ -m64 -DHAVE_RWLOCK_T -DUNIV_SOLARIS -c dbug.c
source='sanity.c' object='sanity.o' libtool=no \
DEPDIR=.deps depmode=none /bin/bash ../depcomp \
cc-5.0 -DHAVE_CONFIG_H -I. -I. -I../include -I../include -I../include -Xa -xstrconst -g -mt -D_FORTEC_ -m64 -DHAVE_RWLOCK_T -DUNIV_SOLARIS -c sanity.c
rm -f libdbug.a
ar cru libdbug.a dbug.o sanity.o
ranlib libdbug.a
source='my_main.c' object='my_main.o' libtool=no \
DEPDIR=.deps depmode=none /bin/bash ../depcomp \
cc-5.0 -DHAVE_CONFIG_H -I. -I. -I../include -I../include -I../include -Xa -xstrconst -g -mt -D_FORTEC_ -m64 -DHAVE_RWLOCK_T -DUNIV_SOLARIS -c my_main.c
source='factorial.c' object='factorial.o' libtool=no \
DEPDIR=.deps depmode=none /bin/bash ../depcomp \
cc-5.0 -DHAVE_CONFIG_H -I. -I. -I../include -I../include -I../include -Xa -xstrconst -g -mt -D_FORTEC_ -m64 -DHAVE_RWLOCK_T -DUNIV_SOLARIS -c factorial.c /bin/bash ../libtool --preserve-dup-deps --tag=CC --mode=link cc-5.0 -Xa -xstrconst -g -mt -D_FORTEC_ -m64 -DHAVE_RWLOCK_T -DUNIV_SOLARIS -o factorial my_main.o factorial.o libdbug.a ../mysys/libmysys.a ../strings/libmystrings.a -lpthread -lthread -lposix4 -lsocket -lnsl -lm -lmtmalloc -lpthread -lthread libtool: link: cc-5.0 -Xa -xstrconst -g -mt -D_FORTEC_ -m64 -DHAVE_RWLOCK_T -DUNIV_SOLARIS -o factorial my_main.o factorial.o libdbug.a ../mysys/libmysys.a ../strings/libmystrings.a -lpthread -lthread -lposix4 -lsocket -lnsl -lm -lmtmalloc -lpthread -lthread -mt
ld: warning: file libdbug.a ignored: unable to locate archive symbol table
ld: warning: file ../mysys/libmysys.a ignored: unable to locate archive symbol table ld: warning: file ../strings/libmystrings.a ignored: unable to locate archive symbol table
Undefined first referenced
symbol in file
my_thread_global_init my_main.o
ld: fatal: Symbol referencing errors. No output written to factorial
gmake[1]: *** [factorial] Error 1
gmake[1]: Leaving directory `/home/mysql/jgrill/mariadb-5.1.42/dbug'
gmake: *** [all-recursive] Error 1

Here's my OS release information:
# cat /etc/release
Solaris 10 10/09 s10x_u8wos_08a X86
Copyright 2009 Sun Microsystems, Inc. All Rights Reserved.
Use is subject to license terms.
Assembled 16 September 2009

Thanks for taking the time to read this far. :-) Any help would be greatly appreciated. I've tried everything I can think of and have spent many hours doing so. I'm pretty excited to try out XtraDB, PBXT, and, of course, MariaDB.

- Jim Grill

Follow ups