← Back to team overview

maria-discuss team mailing list archive

New Question: mysql_secure_installation does not work with socket locations other than /tmp/mysql.sock



A new question has been asked in "MariaDB community" by openiduser32:
The only information I could find on this is a MySQL bug report dating back to 2009: http://bugs.mysql.com/bug.php?id=46842

I've tried passing the basedir to mysql_secure_installation as well as --defaults-file and --socket but it refuses to look anywhere but /tmp/mysql.sock.

I'm running MariaDB in userland and except for this script everything is working fine. My socket file is in ~/mariadb/mysql/run/mysql.sock. Mediawiki has no problem connecting to it using localhost when it's set as the default socket in php.ini. I have network connections disabled in my.cnf to only allowed Unix socket connections. I've tried to fix it myself but I've exhausted my command line scripting knowledge.

Can someone please help me get this script working again?

To view or answer this question please visit: http://mariadb.com/kb/en/mysql_secure_installation-does-not-work-with-socket-locations-other-than-tm/