← Back to team overview

maria-discuss team mailing list archive

slave_compressed_protocol = 1 has no effect


Hi there,

I've been trying to make use of the compressed replication protocol between
two existing MariaDB 10.1.21 boxes.  Replication itself has been working
fine for a while.

I do:

SET GLOBAL slave_compressed_protocol = 1;

On both master and slave.  Then stop/start slave.

However, when I monitor the network usage, I see no reduction in network
traffic.  However, I tried compression via an ssh tunnel and saw a big
reduction (ssh doing the compression, not MariaDB).  So the traffic is
definitely compressible.

I tried setting the param via my.cnf and also restarting both master and
slave to see if that would make a difference - no luck.  Have confirmed the
global variable shows 'ON' after the change, and was 'OFF' before.

Is there potentially an issue with this working with the MariaDB supplied
binary tarball (e.g. some compression lib dependency?)  I see nothing in
error.log to show an issue.  Any other useful ways to debug this?



Follow ups