← Back to team overview

maria-discuss team mailing list archive

Copying database files


I'm using MariaDB 10.2.13 on Windows 7.  All tables are using the Aria engine.

I am trying to initialise a slave database by copying the files between PCs, but when I try and use the copied files I get the error

Table is from another system and must be zerofilled or repaired to be usable on this system

Repairing the tables fixes this, but I'd rather not have to so that.

I have tried various things suggested to stop this, but nothing seems to help. On the source server I have run aria_chk -zerofill on all the tables. Before copying the tables I run FLUSH TABLES <table list> FOR EXPORT, but I still get the error.

What do I need to do to make this work?

Thanks for any help.

Andy Ling

Privileged and/or Confidential information may be contained in this message. If you are not the addressee of this message, you may not copy, use or deliver this message to anyone. In such event, you should destroy the message and kindly notify the sender by reply e-mail. It is understood that opinions or conclusions that do not relate to the official business of the company are neither given nor endorsed by the company. Thank You.

Follow ups