← Back to team overview

maria-discuss team mailing list archive

Re: Mariadb 10.3 crashing continuously on Centos 8


Thanks for your quick reply Gordon!

I will get you the info you asked for soon (no acces to server right now..).
However, I have not touched any of the settings since i installed mariadb in October last year, and it has worked ever since without any issues! That makes me very suspicious.....
I have not been in "my.cnf" (don't even know where that is) as far as I know. To my knowledge, I have not tuned anything, just installed it out of the box.
Are the settings in that file created during a default installation?
Would a forced re-install of all my mariadb rpm's help to put everything back to default, incl all setting files, assuming that this will work?

Anyhow, I will come back to you and the mailing list with the info you asked for as soon as I have access again to the server.

Many Thanks again!


Den 17 maj 2020 16:15, kI 16:15, Gordan Bobic <gordan.bobic@xxxxxxxxx> skrev:
>There are several obvious issues in what you posted, to so with ulimit.
>need to look at your service scripts and make sure that they set
>limits for what you are configuring in my.cnf.
>Are you using the CentOS 8 bundled MariaDB 10.3 or the packages from
>MariaDB repositories?
>Your journalctl output seems incomplete. systemctl status output may
>be useful (make sure neither is truncated in width).
>Comment out all of your tuning options and see if it starts then.
>you know _exactly_ what you are doing or had somebody who _really_
>what they are doing change any options other than
>you should probably leave them at defaults.
>On Sun, May 17, 2020 at 3:00 PM Ralf Hartings <ralf@xxxxxxxxxxx> wrote:
>> Hi
>> My up-to-date Wordpress website running with mariadb 10.3 on CentOS8
>> to date) has been running for a long time without any issues.
>> Suddenly, yesterday, my server became unreachable and did not respond
>> anything. Only power off/on helped to get it to respond again, but
>> website is down.
>> I did not update the server in the last 2 weeks. No changes
>> The logs show the mariadb server is restarting and crashing
>> I switched off the mariadb.service to avoid any possible further
>> as I run a mailserver on the same machine (which runs just fine now).
>> Please look at my post in the CentOS forum:
>> https://forums.centos.org/viewtopic.php?f=54&t=74436&p=313469#p313469
>> The people there are great experts in CentOS, but probably no experts
>> mariadb in the same way as you are, and I really would like to get my
>> site up again ASAP.
>> Thanks a lot for reading this post and helping me out on this!
>> /Ralf
>> _______________________________________________
>> Mailing list: https://launchpad.net/~maria-discuss
>> Post to     : maria-discuss@xxxxxxxxxxxxxxxxxxx
>> Unsubscribe : https://launchpad.net/~maria-discuss
>> More help   : https://help.launchpad.net/ListHelp
>Mailing list: https://launchpad.net/~maria-discuss
>Post to     : maria-discuss@xxxxxxxxxxxxxxxxxxx
>Unsubscribe : https://launchpad.net/~maria-discuss
>More help   : https://help.launchpad.net/ListHelp