← Back to team overview

multi-touch-dev team mailing list archive

Re: unity-2d and GEIS


On 03/07/2011 09:53 PM, Chase Douglas wrote:
> On 03/07/2011 02:15 PM, Florian Boucault wrote:
>> On 03/07/2011 07:53 PM, Henrik Rydberg wrote:
>>> On Mon, Mar 07, 2011 at 07:50:44AM -0700, Duncan McGreggor wrote:
>>>> Hey all,
>>>> Just wanted to let everyone know about something cool...  I was catching
>>>> up with the lead developer for the non-3d/GL(ES) version of Unity (based
>>>> on Qt) today on the phone. He said that unity-2d has been using GEIS for
>>>> the past 3 weeks successfully :-)
>>>> This is great news, as they are using it for all the system-level gestures.
>>>> Keep up the good work, GEIS-casters!
>>> I just tried unity 2d out, and could not see sign of gestures. Perhaps
>>> it has not reached the repos yet?
>>> Cheers,
>>> Henrik
>> It definitely has:
>> - 4 fingers tap toggles the dash
>> - 3 fingers pinch triggers the workspace switcher
>> - 4 fingers drag reveals/hide the launcher (only in Natty)
>> Where are you getting Unity 2D from?
> I installed unity-2d, but none of those gestures work. All my unity-2d
> package versions are 3.6.1-0ubuntu2.
> There is a known geis bug right now:
> https://bugs.launchpad.net/utouch-geis/+bug/728606
> But I tried the fix with no better results.
> -- Chase

I suspect that we have not tested the feature in Natty for some time
now. It works flawlessly in Maverick. I will look into the Natty case as
soon as possible.

Chase, Henrik, can you send me your ~/.xsession-errors file?



Follow ups