← Back to team overview

nova team mailing list archive

Re: Database is locked


Hi Andy,

Thanks for your information.
After erasing nova.sqlite and tried to run nova as root, it solved.


From: Andy Smith [mailto:andyster@xxxxxxxxx]
Sent: Monday, October 25, 2010 2:03 PM
To: RDH 桝本 圭(ITアーキ&セキュ技術)
Cc: nova@xxxxxxxxxxxxxxxxxxx
Subject: Re: [Nova] Database is locked

Last time I got this it was due to initially creating the DB as root but later testing as a regular user. Check your permissions.
On Oct 25, 2010 1:35 PM, <masumotok@xxxxxxxxxxxxx<mailto:masumotok@xxxxxxxxxxxxx>> wrote:
> Hello,
> Now I'm checking Austine Release version of nova.
> And I encounter the below problem.
> Problem: when I tries to euca-run-instance -t m1.small -k testkey ami-tiny,
> Nova-scheduler issued an error "Database is locked"(attached).
> Few seconds later, nova-compute issued an same error(also attached).
> After I checked the behavior, about both cnova-compute and nova-scheduler,
> nova.service.report_state cause this problem. Also, additional information
> is that, in case of scheduler, calling reporting_state got successful twice/
> 3rd just after euca-run-instance.
> My next plan is using MySQL instead of sqlite, b/c
> this "Database is locked" error seems like typical sqlite error.
> But if someone knows solution for it, please let me know.
> Thanks in advance,
> Kei Masumoto
> ------------------------------------------------------------------
> Kei Masumoto <masumotok@xxxxxxxxxxxxx<mailto:masumotok@xxxxxxxxxxxxx>>
> Assistant Manager,
> Research and Development Hq, NTTData Corp.
> tel: +81 50 5546 2301 FAX: +81 3 3532 0491