← Back to team overview

opencog-dev team mailing list archive

Re: doxygen

 

Hi Trent,

Thanks for the suggestions...

On Mon, Jun 9, 2008 at 6:44 PM, Trent Waddington
<trent.waddington@xxxxxxxxx> wrote:
> So, after reading that I feel the taxonomy of TruthValue,
> SimpleTruthValue and IndefiniteTruthValue is false.
>
> I suggest that this taxonomy is hiding the important concept of
> "interval" and, as such, IndefiniteTruthInterval would be a good name
> for the class.  getU() and getL() should be called getLowerBound() and
> getUpperBound(), etc.

The renames from getU and getL to full method names sound good to me.

IndefiniteTruthValue I think could remain as it is. There are also
other TruthValue types, like CompositeTruthValue and
DistributionalTruthValue and using the same name format simplifies
things.

J



Follow ups

References