openerp-community-reviewer team mailing list archive
-
openerp-community-reviewer team
-
Mailing list archive
-
Message #05107
Re: [Merge] lp:~camptocamp/ocb-addons/improve_auth_crypt-nbi into lp:ocb-addons
Ho I got your point Stefan,
I missed the answer of Olivier on addons MP
For this part, your init() method looks fine, but there are already multiple instances of the salting+hashing dance. As you're adding one more, it seems a good opportunity to refactor a bit and extract that pattern into a private method, something like:
def _set_user_password(self, cr, uid, user_id, password, context=None):
password_hash = md5_crypt(password, gen_salt()) # TODO: update default algo in trunk
cr.execute("UPDATE res_users SET password='', password_crypt=%s WHERE id=%s",
(password_hash, user_id))
Yes I should do it
--
https://code.launchpad.net/~camptocamp/ocb-addons/improve_auth_crypt-nbi/+merge/206364
Your team OpenERP Community Backports Team is subscribed to branch lp:ocb-addons.
References