← Back to team overview

openerp-community team mailing list archive

Re: CamelCase

 

The reason for having a convention in the Python world for CamelCase for
classes and under_scores for instances, parameters and modules is to
distinguish them from each other.

In common Python (non-OpenERP) parlance, you would have:

from module import Invoice

invoice = Invoice()

Outside OpenERP, that is would you would expect, I agree, by convention
(but a useful one).

Of course this specific issue is but a tiny detail, but in general, where
possible, I like the idea of being closer to the Python community where it
makes sense.

In other more important issues (code more structured in simple,
unit-testable methods and classes, continuous integration, version/branch
management, documentation...) there are many great examples in the Python
world, and I feel there is space for improvement if we keep an eye outside
what has been done in OpenERP in the past.

That said, I respect your opinion and your vote.




On Fri, Apr 4, 2014 at 4:28 PM, Francesco Apruzzese <cescoap@xxxxxxxxx>wrote:

>
> Il 04/04/2014 16:25, Mariano Ruiz ha scritto:
>
>  I agree with Sylvain, the correct direction is follow the OpenERP SA
> guidelines, and if OpenERP SA will be change to CamelCase, then will be
> good move to this direction all community addons.
>
>
> It's not important WHAT OpenERP SA guidelines say but WHY OpenERP SA
> guidelines say this!
> Why change class name in camel case style? Is this usefull for anything?
>
> _______________________________________________
> Mailing list: https://launchpad.net/~openerp-community
> Post to     : openerp-community@xxxxxxxxxxxxxxxxxxx
> Unsubscribe : https://launchpad.net/~openerp-community
> More help   : https://help.launchpad.net/ListHelp
>
>

References