← Back to team overview

openerp-community team mailing list archive

Re: Class or class_obj


Hi all,

I think everybody agree that _obj is a weak convention. _obj appeals
to an object / an instance.
The alternative proposed suffix is _model. The meaning is clear there.
But personally I find it long when the name of the models is already
I like the idea of the CamelCase (I'm usually following the pep8 rules
but here it would make sense to make an exception) as it would be the
closest to the class that it represents (on the other hand we could
have conflicts if we need a model that is in the same file like
SaleOrderLine as noticed by Yannick Vaucher).

I won't bring the debate much further with my poor arguments... but at
least it was an excuse to share this commit
where odoo is using 2 of them: the meaningless suffix Obj *and* the
CamelCase assignation which upset some people ;-)

Guewen Baconnier

Follow ups