← Back to team overview

openjdk team mailing list archive

Bug#554206: openjdk-6-jre-lib: usr-share-doc-symlink-without-dependency openjdk-6-jre


Package: openjdk-6-jre-lib
Version: 6b16-1.6.1-2
Severity: serious
User: lintian-maint@xxxxxxxxxx
Usertags: usr-share-doc-symlink-without-dependency

If the package installs a symbolic link /usr/share/doc/pkg1 -> pkg2,
then pkg1 has to depend on pkg2 with the same version as pkg1.

Note, that adding the "Depends:" entry just to fix this bug is not a
good solution. It's suggested that you include a real
/usr/share/doc/pkg1 directory within pkg1 and copy the copyright file
into that directory.  If the packages do not share source code, then
pkg1 should have its own copyright file (since the authors of pkg2 are
not to blame for pkg1). This bit covers meta packages as well.

Refer to Debian Policy Manual section 12.5 (Copyright information) for

,----[ 12.5 Copyright information ]
| Every package must be accompanied by a verbatim copy of its copyright
| and distribution license in the file
| /usr/share/doc/package/copyright. This file must neither be compressed
| nor be a symbolic link. `
| ...
| /usr/share/doc/package may be a symbolic link to another directory in
| /usr/share/doc only if the two packages both come from the same source
| and the first package Depends on the second. These rules are important
| because copyrights must be extractable by mechanical means.

This is a bug filed due to a lintian warning (see above). However,
this has also been checked manually, and thus there should be no false

Filed as serious since it is a violation of a must directive in
policy, and also since  a package with these flaws will
currently get this package rejected. See
for details. This means the package has been deemed too buggy to be in


-- System Information:
Debian Release: squeeze/sid
  APT prefers unstable
  APT policy: (990, 'unstable'), (500, 'oldstable'), (500, 'stable')
Architecture: amd64 (x86_64)

Kernel: Linux (SMP w/2 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8) (ignored: LC_ALL set to en_US.UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages openjdk-6-jre-lib depends on:
ii  dpkg                   Debian package management system
ii  openjdk-6-jre-headless      6b16-1.6.1-2 OpenJDK Java runtime, using Hotspo

openjdk-6-jre-lib recommends no packages.

openjdk-6-jre-lib suggests no packages.

-- no debconf information