← Back to team overview

openlp-core team mailing list archive

Re: [Merge] lp:~trb143/openlp/servicing into lp:openlp

 

Review: Approve
Just a note about making some things a little more Pythonic:

  28    frame = QtGui.QPixmap(self.width, self.height)
  29    self.renderer.set_paint_dest(frame)

  Could be written so:

  28    self.renderer.set_paint_dest(QtGui.QPixmap(self.width, self.height))

The usual style police ;-)

  39    answer=self.renderer.render_lines(main_text, footer_text)

You don't really need BOTH of these? Surely just one can be used? And I prefer the top one, as it adds less pollution to the local namespace (I've noticed this in other code too).

  64    from PyQt4 import QtCore, QtGui
  65    from PyQt4.QtCore import *
  66    from PyQt4.QtGui import *

-- 
https://code.launchpad.net/~trb143/openlp/servicing/+merge/6134
Your team openlp.org Core is subscribed to branch lp:openlp.



References