← Back to team overview

openlp-core team mailing list archive

Re: [Merge] lp:~trb143/openlp/audit into lp:openlp

 

Review: Approve
I'll let this through, but please make these changes:

For plugin status, either use a boolean, or use a Python-style "enumeration" like the following:

class PluginStatus(object):
    """
    Status enumeration for plugins.
    """
    Inactive = 0
    Active = 1

plugin[u'status'] = PluginStatus.Active

Also, I don't see why you have a list of dicts with the plugin in the dict, instead of a list of plugin objects. Surely those extra bits of metadata can be properties on the plugin itself?
-- 
https://code.launchpad.net/~trb143/openlp/audit/+merge/12071
Your team openlp.org Core is subscribed to branch lp:openlp.



References