← Back to team overview

openlp-core team mailing list archive

Re: [Merge] lp:~crichter/openlp/i18n into lp:openlp

 

Review: Needs Fixing
This doesn't make sense:

    def setPluginStrings(self):
        """
        Called to define all translatable texts of the plugin
        """
        self.name = u'Plugin'
        self.name_lower = u'plugin'
        self.strings = {}

In this method you have put things that belong in the Plugin class, as well as things that belong in each child plugin class.

self.strings should be set once and for all in the Plugin class, so that it is automatically inherited by all the plugins. In this regard, it would be better for it to be in __init__().

In addition to that, if self.name and self.name_lower are constants, rather than translatable variables, I would rather they went in the __init__() method of each of the plugins.
-- 
https://code.launchpad.net/~crichter/openlp/i18n/+merge/35565
Your team OpenLP Core is subscribed to branch lp:openlp.



References