openlp-core team mailing list archive
-
openlp-core team
-
Mailing list archive
-
Message #29231
Re: [Merge] lp:~suutari-olli/openlp/default-visibility-preset-fixes into lp:openlp
Review: Needs Fixing
We're trying to move toward a standard way of naming boolean values. In essence, the boolean variables should ask a question, and their value should answer that question.
So:
'user interface/is preset layout'
"Is [this a] preset layout?" Yes (True) or No (False)
Could you just rename this please?
Also, tests.
Diff comments:
>
> === modified file 'openlp/core/ui/firsttimewizard.py'
> --- openlp/core/ui/firsttimewizard.py 2016-03-23 11:55:54 +0000
> +++ openlp/core/ui/firsttimewizard.py 2016-04-15 19:16:33 +0000
> @@ -232,17 +239,28 @@
> 'downloaded.'))
> self.download_label.setText(translate('OpenLP.FirstTimeWizard', 'Please wait while OpenLP downloads the '
> 'resource index file...'))
> - self.plugin_page.setTitle(translate('OpenLP.FirstTimeWizard', 'Activate required Plugins'))
> - self.plugin_page.setSubTitle(translate('OpenLP.FirstTimeWizard', 'Select the Plugins you wish to use. '))
> + self.plugin_page.setTitle(translate('OpenLP.FirstTimeWizard', 'Select parts of the program you wish to use'))
> + self.plugin_page.setSubTitle(translate('OpenLP.FirstTimeWizard',
> + 'You can also change these settings after the Wizard.'))
> self.songs_check_box.setText(translate('OpenLP.FirstTimeWizard', 'Songs'))
> - self.custom_check_box.setText(translate('OpenLP.FirstTimeWizard', 'Custom Slides'))
> - self.bible_check_box.setText(translate('OpenLP.FirstTimeWizard', 'Bible'))
> - self.image_check_box.setText(translate('OpenLP.FirstTimeWizard', 'Images'))
> - self.presentation_check_box.setText(translate('OpenLP.FirstTimeWizard', 'Presentations'))
> - self.media_check_box.setText(translate('OpenLP.FirstTimeWizard', 'Media (Audio and Video)'))
> - self.remote_check_box.setText(translate('OpenLP.FirstTimeWizard', 'Allow remote access'))
> - self.song_usage_check_box.setText(translate('OpenLP.FirstTimeWizard', 'Monitor Song Usage'))
> - self.alert_check_box.setText(translate('OpenLP.FirstTimeWizard', 'Allow Alerts'))
> + self.custom_check_box.setText(translate('OpenLP.FirstTimeWizard',
> + 'Custom Slides – Easier to manage than songs and they have their own'
> + ' list of slides'))
> + self.bible_check_box.setText(translate('OpenLP.FirstTimeWizard',
> + 'Bibles – Import and show Bibles'))
> + self.image_check_box.setText(translate('OpenLP.FirstTimeWizard',
> + 'Images – Show images or replace background with them'))
> + self.presentation_check_box.setText(translate('OpenLP.FirstTimeWizard',
> + 'Presentations – Show .ppt, .odp and .pdf presentations'))
> + self.media_check_box.setText(translate('OpenLP.FirstTimeWizard', 'Media – Playback of Audio and Video files'))
> + self.remote_check_box.setText(translate('OpenLP.FirstTimeWizard', 'Remote – Control OpenLP via browser or smart'
> + 'phone app'))
> + self.song_usage_check_box.setText(translate('OpenLP.FirstTimeWizard', 'Song Usage Monitor'))
> + self.alert_check_box.setText(translate('OpenLP.FirstTimeWizard',
> + 'Alerts – Display informative messages while showing other slides'))
> + self.projectors_check_box.setText(translate('OpenLP.FirstTimeWizard',
> + 'Projectors – Allows OpenLP to control PJLink compatible projectors'
> + ' in your network'))
I'm still not entirely happy with this wording... maybe this? "Projectors - Control PJLink compatible projects on your network from OpenLP"
> self.no_internet_page.setTitle(translate('OpenLP.FirstTimeWizard', 'No Internet Connection'))
> self.no_internet_page.setSubTitle(
> translate('OpenLP.FirstTimeWizard', 'Unable to detect an Internet connection.'))
--
https://code.launchpad.net/~suutari-olli/openlp/default-visibility-preset-fixes/+merge/292042
Your team OpenLP Core is subscribed to branch lp:openlp.
References