← Back to team overview

openlp-core team mailing list archive

Re: [Merge] lp:~alisonken1/openlp/strings_init into lp:openlp

 

Review: Needs Fixing



Diff comments:

> === modified file 'openlp/core/__init__.py'
> --- openlp/core/__init__.py	2016-04-04 19:53:54 +0000
> +++ openlp/core/__init__.py	2016-04-24 11:28:59 +0000
> @@ -222,10 +222,11 @@
>                      QtWidgets.QMessageBox.warning(None, translate('OpenLP', 'Backup'),
>                                                    translate('OpenLP', 'Backup of the data folder failed!'))
>                      return
> -                QtWidgets.QMessageBox.information(None, translate('OpenLP', 'Backup'),
> -                                                  translate('OpenLP',
> -                                                            'A backup of the data folder has been created at %s')
> -                                                  % data_folder_backup_path)
> +                message = translate('OpenLP',
> +                                    'A backup of the data folder has been created'
> +                                    'at {text}'.format(text=data_folder_backup_path))

The .format() needs to be outside the translate() call (shown on one line for clarity):

message = translate('OpenLP',  'A backup of the data folder has been created at {text}').format(text=data_folder_backup_path)

> +                QtWidgets.QMessageBox.information(None, translate('OpenLP', 'Backup'), message)
> +
>              # Update the version in the settings
>              Settings().setValue('core/application version', openlp_version)
>  


-- 
https://code.launchpad.net/~alisonken1/openlp/strings_init/+merge/292724
Your team OpenLP Core is subscribed to branch lp:openlp.


References