← Back to team overview

openstack team mailing list archive

Re: Getting pagination right


On Wed, 2011-05-25 at 16:27 -0400, William Wolf wrote:
> I personally like Jay's proposal (except maybe keeping 'pages' out for
> now in favor of just having 1 way to do things, rather than many ways
> to do the same thing), but feel that the term 'marker' should maybe be
> renamed.  Maybe 'timestamp' would even be better? I'm open to other
> suggestions.

Well, it's a consistency mechanism that selects a subset of rows--those
that are visible at a specific time...so perhaps "subset" is a good
self-documenting parameter name?
Kevin L. Mitchell <kevin.mitchell@xxxxxxxxxxxxx>