← Back to team overview

openstack team mailing list archive

Re: Nova string encoding


Isn't the command line interface just a setting on the "terminal" app you are using?

At least on a mac there is a terminal->preferences->advanced which specifies which encoding to use (mine is UTF-8).

Was that tried/verified?

On 2/13/12 3:52 PM, "Andrew Bogott" <abogott@xxxxxxxxxxxxx> wrote:

On 2/13/12 5:04 PM, Naveed Massjouni wrote:
> Very recently, a change got in that converts all tables (except 1) to
> utf8 encoding, for the mysql engine. I manually tested creating
> servers with unicode names and with unicode metadata, and it worked
> fine. Make sure you are running against the latest code. -Naveed

That's a step in the right direction, but doesn't completely address
what I'm asking, unless by 'all tables' you meant 'all tables and also
all internal variables and also all REST and Commandline interfaces.'
Fixing my particular issue is straightforward, but the fact that I'm
seeing the bug in the first place suggests that there's no standard
encoding currently enforced.  Which seems bad.

Mailing list: https://launchpad.net/~openstack
Post to     : openstack@xxxxxxxxxxxxxxxxxxx
Unsubscribe : https://launchpad.net/~openstack
More help   : https://help.launchpad.net/ListHelp

Follow ups