← Back to team overview

ubuntu-phone team mailing list archive

E4.5 Touch-screen problems



This report is about an E4.5 still running the latest OWA15 from
Canonical. After working for years, my device now shows serious issues.
I'm sending this report to the list in the hope that it rings some bell
for someone. After my vacation I will switch to another (UBports E4.5) device
as daily phone, letting this (with its faults) for further
inverstigation. Here is what happened yesterday, from one day to the

The problems started (or were 1st realized) when I wanted to use
the TAB in the terminal-app (to expand directory names). The exact description
of this problem is below #2. But, we start first with the most
dangerous one which turned out after re-boot to try to solve anything.

#1 -- PIN entry

As said, I rebooted and was asked for the PIN of SIM1 (which was 4708).
I realized that not always pressing a digit gave a short signal of that
key (making the press visible) and also not a dot in the line of the PIN.
As there are only dots and no numbers, I can't say what exactly gave the
key press. I'm only sure that I pressed the correct ones. The device said always
(I tried this procedure 5-5 times, resetting the SIM in another E4.5) something like
'Wrong PIN, 2 intents left'. After the second ("wrong") PIN, it raised a warning
box, that it would now be me last attempt and I'd have to use the PUK after
failing again, a box together with an OK-bar to press. Pressing the OK-bar did
not give any visible result and I have had to take out the SIM, reset the
PIN counter in the other E4.5 for the next try from fresh -- same procedure
and same error result. I realized, that (jumping over the PIN entry for the
1st SIM) I could enter fine the PIN for the second SIM (which was 1265).
After 5-6 times of entering the PIN 4708, I changed the PIN of this SIM using the other
E4.5 from 4708 to 1111, i.e. using only the first row of the PIN entry
field. This PIN worked fine now, and the device initialized fine with both

Bottom line: It seems that the PIN entry field gave wrong digits, the first
row (1111) and second row (1265) worked fine.

Change Request: The entered digits should be visible as an option (like they're
in the Wifi or Dekko dialogues, for example).

#2 -- Terminal-app overlay row for layout and special chars

The terminal app starts without the on-screen keyboard (OSK) but with a (orange)
row for changing the "layout" between "Control Keys", "Command Keys", ...
This row works fine, i.e. let change between the layout modes and for example
commands from the "Command Keys" bar are sent and executed in the terminal-app,
or special chars from "Control Keys" like ^C are sent too. It stops working
completely when the OSK is raised, and the row is now above the OSK. It does not
toggle between layout and does not send any char anymore. Btw: This was the 
initial problem I saw which let me re-boot the E4.5 to see if this would
solve this problem.

#3 -- Side bar

I have had on my left side bar to launch apps the following icons (from
bottom to up):

Ubuntu -- dialer -- messages -- contacts -- SystemSetting -- Cam -- ...

Pressing 'SystemSettings' did not start this app anymore from there, only
from the desktop. It started working again what I removed one app below
this ('contacts'). All other app starts from this bar worked fine.

#4 -- Re-boot dialogue

Long pressing the power button gives the dialogue box to choose between
'Power off' / 'Restart' / 'Cancel' as three bars to press, names from
top to down. From this dialogue only 'Power off' and 'Cancel' are working,
the bar 'Restart' does not give any visible result.

Thanks for reading. Any ideas?


Matthias Apitz, ✉ guru@xxxxxxxxxxx, http://www.unixarea.de/ +49-176-38902045
Public GnuPG key: http://www.unixarea.de/key.pub

Follow ups