← Back to team overview

ubuntu-touch-coreapps-reviewers team mailing list archive

Re: [Merge] lp:~nik90/ubuntu-clock-app/predefined-world-city-translation-fix into lp:ubuntu-clock-app

 

> Hey,
> 
> no big mistakes spotted. Seems fine. If you want, for easier readability you
> could perhaps create a method like:
> 
> void addTimeZone(const QString &city, const QString &country, const QString
> &timeZoneName) {
>     TimeZone tz;
>     tz.cityName = city;
>     tz.timeZone = QTimeZone(timeZoneName);

This had to be tz.timeZone QTimeZone(timeZoneName.toLatin1()) for it to work. Was not sure exactly why.

>     tz.country = tr(country);
>     m_timeZones.append(tz);
> }
> 
> and then call a lot of:
> 
> addTimeZone(tr("Anadyr"),     tr("Russia"),         "Asia/Anadyr");
> addTimeZone(tr("Anchorage"),  tr("United States"),  "America/Anchorage");

Yup Done. That looks much better. Thnx :)
-- 
https://code.launchpad.net/~nik90/ubuntu-clock-app/predefined-world-city-translation-fix/+merge/251180
Your team Ubuntu Clock Developers is requested to review the proposed merge of lp:~nik90/ubuntu-clock-app/predefined-world-city-translation-fix into lp:ubuntu-clock-app.


References