← Back to team overview

widelands-dev team mailing list archive

Re: [Merge] lp:~widelands-dev/widelands/request_supply_opt into lp:widelands

 

That should work - but I would suggest to make a tiny private struct to improve readability. 

struct SupplyQuality {
   uint32 distance;
   uint32 serial;

   bool operator<(const SupplyQuality& other) const {
       return std::forward_as_tuple(distance, serial) <  std::forward_as_tuple(other.distance, other.serial);
   }
}


-- 
https://code.launchpad.net/~widelands-dev/widelands/request_supply_opt/+merge/280193
Your team Widelands Developers is subscribed to branch lp:~widelands-dev/widelands/request_supply_opt.


References