widelands-dev team mailing list archive
-
widelands-dev team
-
Mailing list archive
-
Message #17402
Re: [Merge] lp:~widelands-dev/widelands/bug-1830526-soldier-walk-anims into lp:widelands
Review: Approve
Code LGTM - just 1 nit for a variable name
Diff comments:
>
> === modified file 'src/logic/map_objects/tribes/soldier.h'
> --- src/logic/map_objects/tribes/soldier.h 2019-05-18 20:43:25 +0000
> +++ src/logic/map_objects/tribes/soldier.h 2019-05-26 11:50:38 +0000
> @@ -363,6 +367,8 @@
> */
> Battle* battle_;
>
> + std::pair<std::unique_ptr<SoldierLevelRange>, std::unique_ptr<DirAnimations>> cache_walking_animations_;
I'd call this walking_animations_cache_ for consistency - this looks like a function name.
> +
> static constexpr uint8_t kSoldierHealthBarWidth = 13;
>
> /// Number of consecutive blocked signals until the soldiers are considered permanently stuck
--
https://code.launchpad.net/~widelands-dev/widelands/bug-1830526-soldier-walk-anims/+merge/367939
Your team Widelands Developers is subscribed to branch lp:~widelands-dev/widelands/bug-1830526-soldier-walk-anims.
References