← Back to team overview

yade-dev team mailing list archive

Re: [Branch ~yade-dev/yade/trunk] Rev 1874: 1. In utils.facetBox added 'Defence from zero dimensions'

 

> +       if (((extents[0]==0) and (extents[1]==0)) or ((extents[0]==0)
> and (extents[2]==0)) or ((extents[1]==0) and (extents[2]==0))):
> +               raise TypeError("Please, specify at least 2 none-zero
> dimensions in extents!");

Should be RuntimeError, not TypeError (has nothing to do with types,
right?).


> -def gmsh(meshfile="file.mesh",**kw):
> +def gmsh(meshfile="file.mesh",moveTo=[0.0,0.0,0.0],scale=1.0,**kw):
Wouldn't it be better to call it "shift" instead of "moveTo", since the
value is relative? (or at least moveBy or shiftBy, since it is not clear
what point is moved _to_ the moveTo point...)







Follow ups

References