← Back to team overview

yade-dev team mailing list archive

Re: [Branch ~yade-dev/yade/trunk] Rev 2275: Fix of https://bugs.launchpad.net/yade/+bug/589516 (sorry, the compilation did not crash on my co...

 

> -			vector<shared_ptr<Engine> >::iterator itFirst = scene->engines.begin();
> -			vector<shared_ptr<Engine> >::iterator itLast = scene->engines.end();
> -			for ( ;itFirst!=itLast; ++itFirst )
> -			{
Use

	FOREACH(const shared_ptr<Engine>& e, scene->engines){...}

that will make your code a lot more readable.





Follow ups

References