← Back to team overview

yade-users team mailing list archive

Re: [deprecated list] question about lattice model


Jingsong Chen said:     (by the date of Fri, 26 Jun 2009 22:22:56 -0000)

> Hello, everyone!
> First, thank you all for the effort on Yade reference document. I think
> it is very important for the new user (like me) to learn Yade.
> Recently I tried to learn how to use lattice model and I tried the
> latticeExample in Yade (version 0.12rc1), but I found Yade automatically
> quited after I started the simulation for some time and some contents
> (like [New Thread 0xb5fc56e0 (LWP 8331)]) were showed in the terminal.
> Four data files also were generated, but only file (strains) has data.
> So I want to know what's the problem with it and how can I fix it?

if it crashed right after you started calculation, then it's a bug
that I don't know. 

if it crashed after the sample broke, then it is a known bug. It is
related to drawing in OpenGL a rod that is being deleted at the same
time (because it breaks). This does not occur when you close the
OpenGL window.

I never got around to fix this bug, beucase synchronising threads
(display <-> calculation) is so complex. But also, this bug never
bothered me too much, because when some serious calculations are
being run, the OpenGL display is always off (no point to draw
calculations that takes few days, better to look at it after it's

There are few more simple FileGenerator examples in the code in
latest trunk, you might want to try the svn version and see it.

Janek Kozicki                                                         |

Follow ups