← Back to team overview

yade-users team mailing list archive

[Question #695935]: Floating point exception (core dumped)


New question #695935 on Yade:


I was using Ubuntu 18.04 and Yade 2018.02b and the code was running good last year. But several days ago my Ubuntu updated to 20.04 automatically and Yade was also updated to 2020.01a version. Then I found that if I using the same code as in Yade 2018.02b, the particle cloud generated in Yade 2020.01a at different time is not the same. Even I have set the "seed" value in makeCloud command as shown follows, the particle cloud is still changing if I run the code at different time. The code is shown as follows:


Then I install the Yadedaily, the particle cloud can now be generated completely the same if I run it at different time. However, as simulation goes on, another error shows up, the simulation will ends automatically and the terminal shows "Floating point exception (core dumped)". 

I wonder if anyone could help me or give me some suggestions to solve this issue. Is there a bug in "makeCloud" in Yade 2020.01a? Why the Yadedaily will show "Floating point exception (core dumped)"?  If I want to make the code works, should I still install the Yade 2018.02b?

Thank you and kind regards,

You received this question notification because your team yade-users is
an answer contact for Yade.