← Back to team overview

yade-users team mailing list archive

[Question #697791]: yade installation: AttributeError: module 'mpmath.ctx_mp_python' has no attribute 'mpf'


New question #697791 on Yade:


I tried compiling yade in my Ubuntu 20.04 machine. I followed the instructions in [1]. The compilation completed without any errors. However, when I try to run yade, I get the following:

rohit@rkj-hp:~/personal/yade_source/yade_2020/install/bin$ ./yade-2020-11-05.git-7d0ae90
Welcome to Yade 2020-11-05.git-7d0ae90 
Using python version: 3.8.5 (default, May 27 2021, 13:30:53) 
[GCC 9.3.0]
TCP python prompt on localhost:9000, auth cookie `ycaekd'
XMLRPC info provider on http://localhost:21000
Traceback (most recent call last):
  File "./yade-2020-11-05.git-7d0ae90", line 416, in <module>
    import yade.qt
  File "/home/rohit/personal/yade_source/yade_2020/install/lib/x86_64-linux-gnu/yade-2020-11-05.git-7d0ae90/py/yade/qt/__init__.py", line 22, in <module>
    from yade.qt.Inspector import *
  File "/home/rohit/personal/yade_source/yade_2020/install/lib/x86_64-linux-gnu/yade-2020-11-05.git-7d0ae90/py/yade/qt/Inspector.py", line 8, in <module>
    from yade.qt.SerializableEditor import *
  File "/home/rohit/personal/yade_source/yade_2020/install/lib/x86_64-linux-gnu/yade-2020-11-05.git-7d0ae90/py/yade/qt/SerializableEditor.py", line 399, in <module>
AttributeError: module 'mpmath.ctx_mp_python' has no attribute 'mpf'

I tried installing mpmath using pip3 install mpmath and I got the following:
Requirement already satisfied: mpmath in /usr/lib/python3/dist-packages (1.1.0)

How do I fix this? Please let me know if I have missed any information.

Kind regards,
Rohit K. John

[1] https://yade-dem.org/doc/installation.html#source-code

You received this question notification because your team yade-users is
an answer contact for Yade.