← Back to team overview

yade-users team mailing list archive

[Question #705968]: VTKRecorder with recorders=['intr'] leading to Segmentation fault (core dumped)


New question #705968 on Yade:


I am using a compiled version of yade, yade-2022-12-20.git-b582a81 and I have this strange issue.

When I use the VTKRecorder and try to output the interactions (with recorders=['intr'] or recorders=['all']) I usually (sometimes it worked fine, which is even more strange - so I now use a fixed seed) get a Segmentation fault.

This issue happens when I run 05-3d-postprocessing.py for example, or my other scripts. I don't have any issues when I use other types of recorders such as 'spheres', 'velocity', 'facets' etc.

It is also strange that when the simulation stops due to Segmentation fault, the program outputs two VTK files for the interactions:
- 3d-vtk-intrs.1000.vtp
- 3d-vtk-intrs_1000_0.vtp
The first file is totally fine and can be used in Paraview, but the second one is pretty empty.

If anyone knows what could cause this issue I will be grateful. 

Thanks in advance and let me know if you need any further information.

You received this question notification because your team yade-users is
an answer contact for Yade.