← Back to team overview

yahoo-eng-team team mailing list archive

[Bug 1466444] Re: multipath device action incorrectly being parsed as the device name

 

@apahim we are actually trying to traverse the other way, starting with
a single path device and working out the virtual mpath dm device
details. We could actually use a glob to do this instead of `multipath
-l /dev/path` :

~~~
# ll /sys/devices/virtual/block/*/slaves/sdk
lrwxrwxrwx. 1 root root 0 Jun  3 03:56 /sys/devices/virtual/block/dm-2/slaves/sdk -> ../../../../pci0000:00/0000:00:07.0/0000:1a:00.0/host0/rport-0:0-8/target0:0:3/0:0:3:3/block/sdk
~~~

IMHO moving to this method is out of scope for this bug but I will try
to write up a spec detailing how we could use this method in os-brick.


** No longer affects: cinder

** Description changed:

  multipath device action incorrectly being parsed as the device name.
  
  The first word on the first line of `multipath -l $path` is currently
  being used as the name of a given multipath device.
  
  https://github.com/openstack/nova/blob/master/nova/storage/linuxscsi.py#L118
+ https://github.com/openstack/os-brick/blob/master/os_brick/initiator/linuxscsi.py#L145
  
  This however can be an `action:` string when the device is being
  created,  reloaded, resized etc. [1][2][3]
  
  [1] https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Linux/7/html/DM_Multipath/MPIO_output.html
  [2] http://git.opensvc.com/gitweb.cgi?p=multipath-tools/.git;a=blob;f=libmultipath/print.c;h=5d63ed34d2a8816a5e287bdeb1bd90cdb026bb9e;hb=HEAD#l929
  [3] http://git.opensvc.com/gitweb.cgi?p=multipath-tools/.git;a=blob;f=libmultipath/configure.h;h=c014b5533226d9a56571f87b9123de91c5ff1d2f;hb=HEAD

-- 
You received this bug notification because you are a member of Yahoo!
Engineering Team, which is subscribed to OpenStack Compute (nova).
https://bugs.launchpad.net/bugs/1466444

Title:
  multipath device action incorrectly being parsed as the device name

Status in OpenStack Compute (Nova):
  In Progress
Status in Volume discovery and local storage management lib:
  New

Bug description:
  multipath device action incorrectly being parsed as the device name.

  The first word on the first line of `multipath -l $path` is currently
  being used as the name of a given multipath device.

  https://github.com/openstack/nova/blob/master/nova/storage/linuxscsi.py#L118
  https://github.com/openstack/os-brick/blob/master/os_brick/initiator/linuxscsi.py#L145

  This however can be an `action:` string when the device is being
  created,  reloaded, resized etc. [1][2][3]

  [1] https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Linux/7/html/DM_Multipath/MPIO_output.html
  [2] http://git.opensvc.com/gitweb.cgi?p=multipath-tools/.git;a=blob;f=libmultipath/print.c;h=5d63ed34d2a8816a5e287bdeb1bd90cdb026bb9e;hb=HEAD#l929
  [3] http://git.opensvc.com/gitweb.cgi?p=multipath-tools/.git;a=blob;f=libmultipath/configure.h;h=c014b5533226d9a56571f87b9123de91c5ff1d2f;hb=HEAD

To manage notifications about this bug go to:
https://bugs.launchpad.net/nova/+bug/1466444/+subscriptions


References