← Back to team overview

zeitgeist team mailing list archive

[Branch ~zeitgeist/zeitgeist/bluebird] Rev 260: rename peerse to paths and use remove_index_fast instead of remove_index

 

------------------------------------------------------------
revno: 260
committer: Seif Lotfy <seif@xxxxxxxxx>
branch nick: bluebird
timestamp: Sat 2011-09-17 23:28:27 +0200
message:
  rename peerse to paths and use remove_index_fast instead of remove_index
modified:
  src/notify.vala


--
lp:~zeitgeist/zeitgeist/bluebird
https://code.launchpad.net/~zeitgeist/zeitgeist/bluebird

Your team Zeitgeist Framework Team is subscribed to branch lp:~zeitgeist/zeitgeist/bluebird.
To unsubscribe from this branch go to https://code.launchpad.net/~zeitgeist/zeitgeist/bluebird/+edit-subscription
=== modified file 'src/notify.vala'
--- src/notify.vala	2011-09-17 21:20:32 +0000
+++ src/notify.vala	2011-09-17 21:28:27 +0000
@@ -187,12 +187,12 @@
             
             if (connections.lookup (peer) != null)
             {
-                var peers = connections.lookup (peer)
-                for (int i = 0; i < peers.length; i++)
+                var paths = connections.lookup (peer)
+                for (int i = 0; i < paths.length; i++)
                 {
-                    if (peers[i] == object_path)
+                    if (paths[i] == object_path)
                     {
-                        peers.remove_index (i);
+                        paths.remove_index_fast (i);
                         break;
                     }
                 }